织梦CMS - 轻松建站从此开始!

罗索实验室

intel 在LINUX多媒体解码和编码硬件加速

落鹤生 发布于 2013-07-08 09:15 点击:次 
intel hardware-accelerated media decoding and encoding on Linux Hardware Supported Intel GMA X4500HD. Intel HD Graphics (in Intel 2010 Core i7/i5/i3 processor family). Intel HD Graphics 2000/3000 (in 2nd Generation Intel Core i7/i5/i3 Processor fami
TAG:

intel hardware-accelerated media decoding and encoding on Linux
Hardware Supported
Intel® GMA X4500HD.
Intel® HD Graphics (in Intel® 2010 Core™ i7/i5/i3 processor family).
Intel® HD Graphics 2000/3000 (in 2nd Generation Intel® Core™ i7/i5/i3 Processor family, codenamed Sandy Bridge).
Intel® HD Graphics 2500/4000 (in 3rd Generation Intel® Core™ i7/i5/i3 Processor family, codenamed Ivy Bridge).
Features

Support MPEG2 decode acceleration Main Profile @ HL up to 80 Mbps.
Support VC-1 decode acceleration Advanced Profile @ Level 3 up to 40 Mbps (HD Graphics 2000/2500/3000/4000 only).
Support H.264/AVC decode acceleration High Profile @ L4.1 up to 40 Mbps, with:
H.264 / AVC Hardware Variable Length Decoding (VLD) - CABAC
H.264 / AVC Hardware Variable Length Decoding (VLD) - CAVLC
H.264 / AVC Hardware Inverse Transform (IT)
H.264 / AVC Hardware Motion Compensation (HWMC)
H.264 / AVC Hardware In-Loop Deblocking (ILDB)
Support H.264/AVC encode acceleration Main Profile @ L4.1 up to 40 Mbps (HD Graphics 2000/2500/3000/4000 only).

In order to use VA-API, you need a media player that supports it. e.g. VLC 1.1.x, MPlayer with VA-API support, and GStreamer with VA-API support.
Install Instructions
libdrm

./autogen.sh
./configure
make
make install

libva

./autogen.sh (if compiling from a git clone'd repository)
./configure
make
make install

libva-driver-intel

./autogen.sh (if compiling from a git clone'd repository)
./configure
make
make install

mplayer-vaapi

Get MPlayer with VA-API support from mplayer-vaapi on Gitorious
git clone -b hwaccel-vaapi git://gitorious.org/vaapi/mplayer.git mplayer-vaapi

./configure --enable-x11 --enable-vaapi
make
make install

gstreamer-vaapi

Get GStreamer with VA-API support from gstreamer-vaapi on Gitorious
git clone git://gitorious.org/vaapi/gstreamer-vaapi.git gstreamer-vaapi

Dependencies: gstreamer-0.10 >= 0.10.36, gst-plugins-bad >= 0.10.22.

./autogen.sh
./configure
make
make install

Known Issues

During stress testing, sometimes mplayer stops at a frame in some streams

Under certain circumstance, very short period of arrtifacts on one frame when playing back some streams


mplayer-vaapi新立得好象找不到安装包,其它支持有包。

(秩名)
本站文章除注明转载外,均为本站原创或编译欢迎任何形式的转载,但请务必注明出处,尊重他人劳动,同学习共成长。转载请注明:文章转载自:罗索实验室 [http://www1.rosoo.net/a/201307/16685.html]
本文出处:intellinuxgraphics 作者:秩名 原文
顶一下
(0)
0%
踩一下
(0)
0%
------分隔线----------------------------
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 验证码:点击我更换图片
栏目列表
将本文分享到微信
织梦二维码生成器
推荐内容